Re: [PATCH] hostap: avoid uninitialized variable use in hfa384x_get_rid

From: Arnd Bergmann
Date: Thu Jan 28 2016 - 16:57:55 EST


On Wednesday 27 January 2016 19:26:13 Russell King - ARM Linux wrote:
> On Wed, Jan 27, 2016 at 02:45:26PM +0100, Arnd Bergmann wrote:
> So, why give the compiler a hard time as you're doing, why make the code
> harder to read. What's wrong with:
>
> spin_lock_bh(&local->baplock);
>
> res = hfa384x_setup_bap(dev, BAP0, rid, 0);
> if (res)
> goto unlock;
>
> res = hfa384x_from_bap(dev, BAP0, &rec, sizeof(rec));
> if (res)
> goto unlock;
>
> if (le16_to_cpu(rec.len) == 0) {
> /* RID not available */
> res = -ENODATA;
> goto unlock;
> }
>
> rlen = (le16_to_cpu(rec.len) - 1) * 2;
> if (exact_len && rlen != len) {
> printk(KERN_DEBUG "%s: hfa384x_get_rid - RID len mismatch: rid=0x%04x, len=%d (expected %d)\n",
> dev->name, rid, rlen, len);
> res = -ENODATA;
> goto unlock;
> }
>
> res = hfa384x_from_bap(dev, BAP0, buf, len);
> unlock:
> spin_unlock_bh(&local->baplock);
>
> ?
>

Good idea, I'll send a new version.

Arnd