Re: [PATCH 1/7] char: xillybus: use to_delayed_work

From: Eli Billauer
Date: Fri Jan 01 2016 - 15:04:59 EST


Hello,

It's fine with me, but this patch needs to go to the char and misc drivers maintainers (i.e. Arnd Bergmann and Greg Kroah-Hartman). I don't have a repository of my own.

Thanks,
Eli

Acked-by: Eli Billauer <eli.billauer@xxxxxxxxx>

On 01/01/16 16:59, Geliang Tang wrote:
Use to_delayed_work() instead of open-coding it.

Signed-off-by: Geliang Tang<geliangtang@xxxxxxx>
---
drivers/char/xillybus/xillybus_core.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)

diff --git a/drivers/char/xillybus/xillybus_core.c b/drivers/char/xillybus/xillybus_core.c
index 77d6c12..3bd36e0 100644
--- a/drivers/char/xillybus/xillybus_core.c
+++ b/drivers/char/xillybus/xillybus_core.c
@@ -1164,8 +1164,7 @@ static int xillybus_flush(struct file *filp, fl_owner_t id)

static void xillybus_autoflush(struct work_struct *work)
{
- struct delayed_work *workitem = container_of(
- work, struct delayed_work, work);
+ struct delayed_work *workitem = to_delayed_work(work);
struct xilly_channel *channel = container_of(
workitem, struct xilly_channel, rd_workitem);
int rc;

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/