Re: [PATCH 05/10] mmc: cb710: use to_platform_device()

From: Ulf Hansson
Date: Mon Dec 28 2015 - 08:29:58 EST


On 27 December 2015 at 14:15, Geliang Tang <geliangtang@xxxxxxx> wrote:
> Use to_platform_device() instead of open-coding it.
>
> Signed-off-by: Geliang Tang <geliangtang@xxxxxxx>

Thanks, applied for next!

Kind regards
Uffe

> ---
> drivers/mmc/host/cb710-mmc.h | 3 +--
> 1 file changed, 1 insertion(+), 2 deletions(-)
>
> diff --git a/drivers/mmc/host/cb710-mmc.h b/drivers/mmc/host/cb710-mmc.h
> index 8984ec8..8ecd9e5 100644
> --- a/drivers/mmc/host/cb710-mmc.h
> +++ b/drivers/mmc/host/cb710-mmc.h
> @@ -29,8 +29,7 @@ static inline struct mmc_host *cb710_slot_to_mmc(struct cb710_slot *slot)
>
> static inline struct cb710_slot *cb710_mmc_to_slot(struct mmc_host *mmc)
> {
> - struct platform_device *pdev = container_of(mmc_dev(mmc),
> - struct platform_device, dev);
> + struct platform_device *pdev = to_platform_device(mmc_dev(mmc));
> return cb710_pdev_to_slot(pdev);
> }
>
> --
> 2.5.0
>
>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/