Re: [PATCH] ARM64: Clear out any singlestep state on a ptrace detach operation

From: Oleg Nesterov
Date: Sat Dec 05 2015 - 13:48:57 EST


On 12/04, Will Deacon wrote:
>
> I hacked up a quick patch below (not even compile-tested), but I'm not
> sure what to do about hardware {break,watch}points. Some architectures
> explicitly clear those on detach, whereas others appear to leave them
> alone. Thoughts?

Heh ;)

Please see fab840fc2d542fabcab "ptrace: PTRACE_DETACH should do
flush_ptrace_hw_breakpoint(child)".

And the next "revert" commit, 35114fcbe0b9b0fa3f6653a2.

> --- a/kernel/ptrace.c
> +++ b/kernel/ptrace.c
> @@ -454,13 +454,20 @@ static bool __ptrace_detach(struct task_struct *tracer, struct task_struct *p)
> return dead;
> }
>
> +#ifndef arch_ptrace_detach
> +#define arch_ptrace_detach(child) do { } while (0)
> +#endif
> +
> static int ptrace_detach(struct task_struct *child, unsigned int data)
> {
> if (!valid_signal(data))
> return -EIO;
>
> - /* Architecture-specific hardware disable .. */
> - ptrace_disable(child);
> + arch_ptrace_detach(child);
> + user_disable_single_step(child);
> +#ifdef TIF_SYSCALL_EMU
> + clear_tsk_thread_flag(child, TIF_SYSCALL_EMU);
> +#endif
> clear_tsk_thread_flag(child, TIF_SYSCALL_TRACE);

Well, personally I'd prefer to keep the arch-dependent ptrace_disable(), this
just looks safer to me. Although I agree that its name is bad and
arch_ptrace_detach() looks much better.

Oleg.

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/