Re: [PATCH v4 3/3] arm64: dts: mt8173: Add nor flash node

From: Daniel Kurtz
Date: Wed Oct 14 2015 - 07:27:07 EST


Sergei,

On Wed, Oct 14, 2015 at 7:05 PM, Sergei Shtylyov
<sergei.shtylyov@xxxxxxxxxxxxxxxxxx> wrote:
> Hello.
>
> On 10/14/2015 4:07 AM, Daniel Kurtz wrote:
>
>>>> Add Mediatek nor flash node
>>>>
>>>> Signed-off-by: Bayi Cheng <bayi.cheng@xxxxxxxxxxxx>
>>>> ---
>>>> arch/arm64/boot/dts/mediatek/mt8173.dtsi | 15 +++++++++++++++
>>>> 1 file changed, 15 insertions(+)
>>>>
>>>> diff --git a/arch/arm64/boot/dts/mediatek/mt8173.dtsi
>>>> b/arch/arm64/boot/dts/mediatek/mt8173.dtsi
>>>> index d18ee42..385c2e4 100644
>>>> --- a/arch/arm64/boot/dts/mediatek/mt8173.dtsi
>>>> +++ b/arch/arm64/boot/dts/mediatek/mt8173.dtsi
>>>> @@ -365,6 +365,21 @@
>>>> status = "disabled";
>>>> };
>>>>
>>>> + nor_flash: spi@1100d000 {
>>>
>>>
>>> I don't think this is a good label name for a SPI controller.
>>
>>
>> You think "spi" is not a good name for SPI controller?
>> Or you mean the label "nor_flash"?
>
>
> I think I said clearly: "label". :-)
>
>> Would you prefer:
>>
>> spi_nor_flash: spi@1100d000
>
>
> I'd prefer the "_nor_flash" part to be dropped, to be used for the real
> flash device (if needed) which is a sub-node of this node.

The dedicated nor_flash spi bus cannot just be labeled 'spi', as that
would conflict with the general purpose 'spi' bus. Instead, it is
given a unique label that can be used as a phandle elsewhere (e.g., in
a board file, to enable the bus). The name "spi_nor_flash" makes it
clear that this spi bus is only for use for accessing the nor_flash.

Bayi: Actually, this reminds me. I'd prefer if the bus node was
disabled by default, and only enabled by boards as required. So, the
node should include:
status = "disabled";

-Dan
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/