Re: [PATCH 3/6] watchdog: at91sam9: rename heartbeats into timeout where necessary

From: Sylvain Rochet
Date: Mon Oct 12 2015 - 06:07:18 EST


On Thu, Oct 08, 2015 at 11:34:31PM +0200, Sylvain Rochet wrote:
>
> @@ -344,7 +342,7 @@ static int __init at91wdt_probe(struct platform_device *pdev)
> wdt->wdd.parent = &pdev->dev;
> wdt->wdd.info = &at91_wdt_info;
> wdt->wdd.ops = &at91_wdt_ops;
> - wdt->wdd.timeout = WDT_HEARTBEAT;
> + wdt->wdd.timeout = wdt_timeout;

This wasn't a good idea, if wdt_timeout is set using a module parameter
to a wrong value we end up using this wrong value. Setting the default
to a valid hardwired value and checking if the proposed value is valid
using watchdog_init_timeout is obviously the way to go. I will rework
that in v2.

Sylvain
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/