Re: [PATCH v2 05/14] RDS: defer the over_batch work to send worker

From: David Miller
Date: Mon Oct 05 2015 - 06:15:17 EST


From: Santosh Shilimkar <santosh.shilimkar@xxxxxxxxxx>
Date: Wed, 30 Sep 2015 13:24:24 -0400

> @@ -423,7 +423,9 @@ over_batch:
> !list_empty(&conn->c_send_queue)) &&
> send_gen == conn->c_send_gen) {
> rds_stats_inc(s_send_lock_queue_raced);
> - goto restart;
> + if (batch_count < 1024)
> + goto restart;
> + queue_delayed_work(rds_wq, &conn->c_send_w, 1);

Sorry, you can't just use a magic number like this.

You have to describe, in detail, exactly how this value was
choosen, derived, and tested to be effeective and in exactly
what environment those tests were done.

You must also use a mnenomic for this value rather than a
raw magic constant.

Thanks.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/