Re: [PATCH 1/3] signal: turn dequeue_signal_lock() into kernel_dequeue_signal()

From: Tejun Heo
Date: Sun Oct 04 2015 - 12:39:14 EST


On Sat, Oct 03, 2015 at 08:13:36PM +0200, Oleg Nesterov wrote:
> 1. Rename dequeue_signal_lock() to kernel_dequeue_signal(). This
> matches another "for kthreads only" kernel_sigaction() helper.
>
> 2. Remove the "tsk" and "mask" arguments, they are always current
> and current->blocked. And it is simply wrong if tsk != current.
>
> 3. We could also remove the 3rd "siginfo_t *info" arg but it looks
> potentially useful. However we can simplify the callers if we
> change kernel_dequeue_signal() to accept info => NULL.
>
> 4. Remove _irqsave, it is never called from atomic context.
>
> Signed-off-by: Oleg Nesterov <oleg@xxxxxxxxxx>

FWIW, looks good to me.

Reviewed-by: Tejun Heo <tj@xxxxxxxxxx>

Thanks.

--
tejun
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/