Re: [RFC][PATCH 02/11] sched: Create preempt_count invariant

From: Peter Zijlstra
Date: Tue Sep 29 2015 - 10:15:57 EST


On Tue, Sep 29, 2015 at 03:11:56PM +0200, Thomas Gleixner wrote:
> On Tue, 29 Sep 2015, Peter Zijlstra wrote:
> > + /*
> > + * Still have preempt_count() == 2, from:
> > + *
> > + * schedule()
> > + * preempt_disable(); // 1
> > + * __schedule()
> > + * raw_spin_lock_irq(&rq->lock) // 2
> > + */
> > + rq = finish_task_switch(prev); /* drops rq->lock, preempt_count() == 1 */
> > balance_callback(rq);
> > - preempt_enable();
> > + preempt_enable(); /* preempt_count() == 0 */
>
> Bah. I so hate tail comments. What's wrong with
>
> + /* preempt_count() ==> 0 */
> preempt_enable();
>
> Hmm?

I find the tail comments more readable in this case; clearly I don't
share your hatred :-). But I can change them if you insist.

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/