[PATCH 00/14] RFC: Consolidation: FUSB200 and FOTG210

From: Peter Senna Tschudin
Date: Mon Sep 21 2015 - 11:01:34 EST


I'm working on the consolidation of two very similar Faraday EHCI drivers:

drivers/usb/host/fusbh200-hcd.c and drivers/usb/host/fotg210-hcd.c

I'm sending the work unfinished because I have some questions, and I would
appreciate feedback about the changes. As this is not complete work, please do
_not_ apply the series.

Patches from 01 to 10 are fixes to issues reported by checkpatch, patches 11,
12 and 13 are changes to prepare the code to support multiple devices, and
patch 14 adds parameters from fusb200 into faraday-hcd.

My questions:
- Is the name faraday-hcd good for the driver that will support both
fusb200-hcd and fotg210-hcd?

- Is this patch series in a good direction for consolidating the two drivers?
I mean it is a lot of patches, and there are many different orders in which
I could send them.

- Is it a good idea to include now changes like patches 06, 09 and 10 that may
have impact on performance? Or should I wait until I can get some hw to
test?

- Do you know easy to find and cheap devices using this two host controllers?

- Should I worry about drivers/usb/gadget/udc/fotg210-udc.c?

Peter Senna Tschudin (14):
usb/host/fotg210: Fix coding style issues
usb/host/fotg210: remove KERN_WARNING from pr_info
usb/host/fotg210: Remove useless else statement
usb/host/fotg210: Remove NULL checks dma_pool_destroy
usb/host/fotg210: change kmalloc by kmalloc_array
usb/host/fotg210: replace msleep by usleep_range
usb/host/fotg210: Remove a macro from a call to snprintf
usb/host/fotg210: convert macro to inline function
usb/host/fotg210: Add function: output_buf_tds_dir()
usb/host/fotg210: Add function scan_frame_queue()
usb/host: Rename fotg210-hcd to faraday-hcd
usb/host/faraday-hcd: Replace fotg210 by fhcd2xx
usb/host/faraday-hcd: Move #defines outside struct
usb/host/faraday-hcd: Import FUSBH200 parameters

drivers/usb/host/Kconfig | 2 +-
drivers/usb/host/Makefile | 2 +-
drivers/usb/host/faraday-hcd.c | 5792 ++++++++++++++++++++++++++++++++++++++
drivers/usb/host/faraday-hcd.h | 751 +++++
drivers/usb/host/fotg210-hcd.c | 5951 ----------------------------------------
drivers/usb/host/fotg210.h | 686 -----
6 files changed, 6545 insertions(+), 6639 deletions(-)
create mode 100644 drivers/usb/host/faraday-hcd.c
create mode 100644 drivers/usb/host/faraday-hcd.h
delete mode 100644 drivers/usb/host/fotg210-hcd.c
delete mode 100644 drivers/usb/host/fotg210.h

--
2.1.0

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/