Re: [PATCH] char: ipmi: Move MODULE_DEVICE_TABLE() to follow struct

From: Corey Minyard
Date: Sat Sep 19 2015 - 20:46:53 EST


Ok, queued for 4.4.

Thanks,

-corey

On 09/19/2015 10:43 AM, Luis de Bethencourt wrote:
> The policy for drivers is to have MODULE_DEVICE_TABLE() just after the
> struct used in it. For clarity.
>
> Suggested-by: Corey Minyard <minyard@xxxxxxx>
> Signed-off-by: Luis de Bethencourt <luisbg@xxxxxxxxxxxxxxx>
> ---
>
> Suggested in:
> https://lkml.org/lkml/2015/9/18/842
>
> Thanks Corey,
> Luis
>
> drivers/char/ipmi/ipmi_si_intf.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/char/ipmi/ipmi_si_intf.c b/drivers/char/ipmi/ipmi_si_intf.c
> index 654f6f3..061fef0 100644
> --- a/drivers/char/ipmi/ipmi_si_intf.c
> +++ b/drivers/char/ipmi/ipmi_si_intf.c
> @@ -2560,6 +2560,7 @@ static const struct of_device_id of_ipmi_match[] = {
> .data = (void *)(unsigned long) SI_BT },
> {},
> };
> +MODULE_DEVICE_TABLE(of, of_ipmi_match);
>
> static int of_ipmi_probe(struct platform_device *dev)
> {
> @@ -2646,7 +2647,6 @@ static int of_ipmi_probe(struct platform_device *dev)
> }
> return 0;
> }
> -MODULE_DEVICE_TABLE(of, of_ipmi_match);
> #else
> #define of_ipmi_match NULL
> static int of_ipmi_probe(struct platform_device *dev)

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/