Re: [PATCH V3] mmc: block: Add new ioctl to send multi commands

From: Ulf Hansson
Date: Thu Sep 17 2015 - 02:59:45 EST


[...]

>>> + /*
>>> + * The caller must have CAP_SYS_RAWIO, and must be calling this on the
>>> + * whole block device, not on a partition. This prevents overspray
>>> + * between sibling partitions.
>>> + */
>>> + if ((!capable(CAP_SYS_RAWIO)) || (bdev != bdev->bd_contains))
>>> + return -EPERM;
>>
>> This check is common for multi and non-multi. Please move it to the
>> mmc_blk_ioctl() to avoid some code duplication.
>
> Yes that's true. I can move but it means also passing bdev to
> __mmc_blk_ioctl_cmd() as another argument. It is not a big deal, but it
> was more convenient to test here. If your preference is to consolidate
> the tests to one place then I will move this test.

I was suggesting to move it to mmc_blk_ioctl() and not to
__mmc_blk_ioctl_cmd(). That shouldn't cause any changes to any
function-definitions, right!?

Kind regards
Uffe
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/