Re: [PATCH 3/8] jump_label: introduce DEFINE_STATIC_KEY_{TRUE,FALSE}_ARRAY macros

From: Kevin Hao
Date: Fri Aug 21 2015 - 02:35:19 EST


On Fri, Aug 21, 2015 at 08:28:26AM +0200, Ingo Molnar wrote:
>
> * Kevin Hao <haokexin@xxxxxxxxx> wrote:
>
> > These are used to define a static_key_{true,false} array.
> >
> > Signed-off-by: Kevin Hao <haokexin@xxxxxxxxx>
> > ---
> > include/linux/jump_label.h | 6 ++++++
> > 1 file changed, 6 insertions(+)
> >
> > diff --git a/include/linux/jump_label.h b/include/linux/jump_label.h
> > index 7f653e8f6690..5c1d6a49dd6b 100644
> > --- a/include/linux/jump_label.h
> > +++ b/include/linux/jump_label.h
> > @@ -267,6 +267,12 @@ struct static_key_false {
> > #define DEFINE_STATIC_KEY_FALSE(name) \
> > struct static_key_false name = STATIC_KEY_FALSE_INIT
> >
> > +#define DEFINE_STATIC_KEY_TRUE_ARRAY(name, n) \
> > + struct static_key_true name[n] = { [0 ... n - 1] = STATIC_KEY_TRUE_INIT }
> > +
> > +#define DEFINE_STATIC_KEY_FALSE_ARRAY(name, n) \
> > + struct static_key_false name[n] = { [0 ... n - 1] = STATIC_KEY_FALSE_INIT }
>
> I think the define makes the code more obfuscated and less clear, the open-coded
> initialization is pretty dense and easy to read to begin with.

OK, I will drop this patch and move the initialization of the array to the
corresponding patch.

Thanks,
Kevin

Attachment: pgpGIHVnOBx74.pgp
Description: PGP signature