Re: [PATCH v2 05/16] x86/efi: Get entropy through EFI random number generator protocol

From: Matt Fleming
Date: Thu Aug 20 2015 - 10:47:27 EST


On Tue, 11 Aug, at 02:16:25PM, Lee, Chun-Yi wrote:
> To grab random numbers through EFI protocol as one of the entropies
> source of swsusp key, this patch adds the logic for accessing EFI RNG
> (random number generator) protocol that's introduced since UEFI 2.4.
>
> Signed-off-by: Lee, Chun-Yi <jlee@xxxxxxxx>
> ---
> arch/x86/boot/compressed/efi_random.c | 209 ++++++++++++++++++++++++++++++++++
> include/linux/efi.h | 13 +++
> 2 files changed, 222 insertions(+)

[...]

Most of this looks good.

> +static unsigned long efi_get_rng(efi_system_table_t *sys_table)
> +{
> + const struct efi_config *efi_early = __efi_early();
> + unsigned long random = 0;
> + efi_status_t status;
> + void **rng_handle = NULL;
> +
> + status = efi_locate_rng(sys_table, &rng_handle);
> + if (status != EFI_SUCCESS)
> + return 0;
> +
> + if (efi_early->is64)
> + random = efi_get_rng64(sys_table, rng_handle);
> + else
> + random = efi_get_rng32(sys_table, rng_handle);
> +
> + efi_call_early(free_pool, rng_handle);
> +
> + return random;
> +}

I think this function is named particularly poorly in the UEFI spec
(GetRNG), can we maybe make this efi_get_rng_number(),
efi_get_rng_value() or efi_get_rng_long() to match the existing
naming?

> diff --git a/include/linux/efi.h b/include/linux/efi.h
> index 85ef051..8914d60 100644
> --- a/include/linux/efi.h
> +++ b/include/linux/efi.h
> @@ -427,6 +427,16 @@ typedef struct {
> #define EFI_PCI_IO_ATTRIBUTE_VGA_PALETTE_IO_16 0x20000
> #define EFI_PCI_IO_ATTRIBUTE_VGA_IO_16 0x40000
>
> +typedef struct {
> + u32 get_info;
> + u32 get_rng;
> +} efi_rng_protocol_32;
> +
> +typedef struct {
> + u64 get_info;
> + u64 get_rng;
> +} efi_rng_protocol_64;
> +

We've been kinda slack with the naming conventions in efi.h but these
should really both be 'efi_rng_protocol_*_t'.

--
Matt Fleming, Intel Open Source Technology Center
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/