Re: [PATCH v3 13/51] PCI: Separate realloc list checking after allocation

From: Yinghai Lu
Date: Tue Aug 18 2015 - 17:58:14 EST


On Mon, Aug 17, 2015 at 4:54 PM, Bjorn Helgaas <bhelgaas@xxxxxxxxxx> wrote:
> On Mon, Jul 27, 2015 at 04:29:31PM -0700, Yinghai Lu wrote:
>> We check the realloc list, as list must be empty after allocation.
>>
>> Separate the realloc list checking to another function.
>>
>> Add checking that is missed in acpiphp driver.
>>
>> Signed-off-by: Yinghai Lu <yinghai@xxxxxxxxxx>
>> Cc: "Rafael J. Wysocki" <rjw@xxxxxxxxxxxxx>
>> Cc: Len Brown <lenb@xxxxxxxxxx>
>> Cc: linux-acpi@xxxxxxxxxxxxxxx
>> ---
>> drivers/pci/hotplug/acpiphp_glue.c | 1 +
>> drivers/pci/pci.h | 1 +
>> drivers/pci/setup-bus.c | 11 ++++++++---
>> 3 files changed, 10 insertions(+), 3 deletions(-)
>>
>> diff --git a/drivers/pci/hotplug/acpiphp_glue.c b/drivers/pci/hotplug/acpiphp_glue.c
>> index ff53856..134caee 100644
>> --- a/drivers/pci/hotplug/acpiphp_glue.c
>> +++ b/drivers/pci/hotplug/acpiphp_glue.c
>> @@ -507,6 +507,7 @@ static void enable_slot(struct acpiphp_slot *slot)
>> }
>> }
>> __pci_bus_assign_resources(bus, &add_list, NULL);
>> + __pci_bus_check_realloc(&add_list);
>>
>> acpiphp_sanitize_bus(bus);
>> pcie_bus_configure_settings(bus);
>> diff --git a/drivers/pci/pci.h b/drivers/pci/pci.h
>> index 4ff0ff1..2b83977 100644
>> --- a/drivers/pci/pci.h
>> +++ b/drivers/pci/pci.h
>> @@ -235,6 +235,7 @@ void __pci_bus_size_bridges(struct pci_bus *bus,
>> void __pci_bus_assign_resources(const struct pci_bus *bus,
>> struct list_head *realloc_head,
>> struct list_head *fail_head);
>> +void __pci_bus_check_realloc(struct list_head *realloc_head);
>> bool pci_bus_clip_resource(struct pci_dev *dev, int idx);
>>
>> void pci_reassigndev_resource_alignment(struct pci_dev *dev);
>> diff --git a/drivers/pci/setup-bus.c b/drivers/pci/setup-bus.c
>> index 06664db..f30225c 100644
>> --- a/drivers/pci/setup-bus.c
>> +++ b/drivers/pci/setup-bus.c
>> @@ -350,6 +350,11 @@ out:
>> }
>> }
>>
>> +void __pci_bus_check_realloc(struct list_head *realloc_head)
>> +{
>> + BUG_ON(!list_empty(realloc_head));
>
> I don't think this really improves readability. At least before, we could
> see what we were looking for and we knew it might BUG().

ok, will only missing BUG_ON into acpiphp_glue.c.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/