Re: [PATCH] usb: move assignment out of if condition

From: Oliver Neukum
Date: Tue Jun 30 2015 - 09:36:41 EST


On Tue, 2015-06-30 at 09:02 -0400, Kris Borer wrote:
> Fix four occurrences of the checkpatch.pl error:
>
> ERROR: do not use assignment in if condition
>
> Signed-off-by: Kris Borer <kborer@xxxxxxxxx>

Sorry, but NACK!
Those patches are totally broken.

> ---
> drivers/usb/core/hcd.c | 13 ++++++++-----
> 1 file changed, 8 insertions(+), 5 deletions(-)
>
> diff --git a/drivers/usb/core/hcd.c b/drivers/usb/core/hcd.c
> index be5b207..e268c45 100644
> --- a/drivers/usb/core/hcd.c
> +++ b/drivers/usb/core/hcd.c
> @@ -2683,12 +2683,13 @@ int usb_add_hcd(struct usb_hcd *hcd,
> * bottom up so that hcds can customize the root hubs before hub_wq
> * starts talking to them. (Note, bus id is assigned early too.)
> */
> - if ((retval = hcd_buffer_create(hcd)) != 0) {
> + retval = hcd_buffer_create(hcd);
> + if (retval != 0) {
> dev_dbg(hcd->self.controller, "pool alloc failed\n");
> goto err_create_buf;
> }
> -
> - if ((retval = usb_register_bus(&hcd->self)) < 0)
> + retval = usb_register_bus(&hcd->self);
> + if (retval < 0)
> goto err_register_bus;
>
> rhdev = usb_alloc_dev(NULL, &hcd->self, 0);
> @@ -2734,7 +2735,8 @@ int usb_add_hcd(struct usb_hcd *hcd,
> /* "reset" is misnamed; its role is now one-time init. the controller
> * should already have been reset (and boot firmware kicked off etc).
> */
> - if (hcd->driver->reset && (retval = hcd->driver->reset(hcd)) < 0) {
> + retval = hcd->driver->reset(hcd);

You happily follow the NULL pointer.

Regards
Oliver


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/