Re: [PATCH v2 1/9] topology: rename topology_thread_cpumask()

From: Russell King - ARM Linux
Date: Wed May 06 2015 - 07:27:47 EST


On Mon, May 04, 2015 at 12:28:16PM +0200, Bartosz Golaszewski wrote:
> Rename topology_thread_cpumask() to topology_sibling_cpumask() for
> more consistency with scheduler code.
>
> Signed-off-by: Bartosz Golaszewski <bgolaszewski@xxxxxxxxxxxx>

Acked-by: Russell King <rmk+kernel@xxxxxxxxxxxxxxxx>

for:

> arch/arm/include/asm/topology.h | 2 +-

> diff --git a/arch/arm/include/asm/topology.h b/arch/arm/include/asm/topology.h
> index 2fe85ff..370f7a7 100644
> --- a/arch/arm/include/asm/topology.h
> +++ b/arch/arm/include/asm/topology.h
> @@ -18,7 +18,7 @@ extern struct cputopo_arm cpu_topology[NR_CPUS];
> #define topology_physical_package_id(cpu) (cpu_topology[cpu].socket_id)
> #define topology_core_id(cpu) (cpu_topology[cpu].core_id)
> #define topology_core_cpumask(cpu) (&cpu_topology[cpu].core_sibling)
> -#define topology_thread_cpumask(cpu) (&cpu_topology[cpu].thread_sibling)
> +#define topology_sibling_cpumask(cpu) (&cpu_topology[cpu].thread_sibling)
>
> void init_cpu_topology(void);
> void store_cpu_topology(unsigned int cpuid);

Thanks.

--
FTTC broadband for 0.8mile line: currently at 10.5Mbps down 400kbps up
according to speedtest.net.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/