Re: [PATCH 5/6] x86: replace cpu_**_mask() with topology_**_cpumask()

From: Ingo Molnar
Date: Sat May 02 2015 - 02:34:12 EST



* Bartosz Golaszewski <bgolaszewski@xxxxxxxxxxxx> wrote:

> The former duplicate the functionalities of the latter but are neither
> documented nor arch-independent.

> if (!has_mp) {
> - cpumask_set_cpu(cpu, cpu_sibling_mask(cpu));
> + cpumask_set_cpu(cpu, topology_thread_cpumask(cpu));
> cpumask_set_cpu(cpu, cpu_llc_shared_mask(cpu));

So why does topology.h invent a new name for 'sibling CPUs'?

At least in the scheduling context, 'sibling' is the term we are using
in most places in the scheduler - try 'git grep sibling kernel/sched/'.

'thread' is a bad name anyway for a CPU, even if we didn't have an
existing term for it.

So please rename topology_thread_cpumask to topology_sibling_cpumask
to not replace one inconsistency for another one ...

Thanks,

Ingo
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/