Re: [PATCH 1/3] timer: Allocate per-cpu tvec_base's statically

From: Ingo Molnar
Date: Tue Mar 31 2015 - 03:46:03 EST



* Viresh Kumar <viresh.kumar@xxxxxxxxxx> wrote:

> From: Peter Zijlstra <peterz@xxxxxxxxxxxxx>
>
> Memory for tvec_base is allocated separately for boot CPU (statically) and
> non-boot CPUs (dynamically).
>
> The reason is because __TIMER_INITIALIZER() needs to set ->base to a valid
> pointer (because we've made NULL special, hint: lock_timer_base()) and we cannot
> get a compile time pointer to per-cpu entries because we don't know where we'll
> map the section, even for the boot cpu.
>
> This can be simplified a bit by statically allocating per-cpu memory. The only
> disadvantage is that memory for one of the structures will stay unused, i.e. for
> the boot CPU, which uses boot_tvec_bases.
>
> This will also guarantee that tvec_base is cacheline aligned. Even though
> tvec_base has ____cacheline_aligned stuck on, kzalloc_node() does not actually
> respect that (but guarantees a minimum u64 alignment).
>
> Signed-off-by: Peter Zijlstra <peterz@xxxxxxxxxxxxx>
> Signed-off-by: Viresh Kumar <viresh.kumar@xxxxxxxxxx>
> ---
> kernel/time/timer.c | 36 ++++++++----------------------------
> 1 file changed, 8 insertions(+), 28 deletions(-)
>
> diff --git a/kernel/time/timer.c b/kernel/time/timer.c
> index 2d3f5c504939..6e8220ec8a62 100644
> --- a/kernel/time/timer.c
> +++ b/kernel/time/timer.c
> @@ -93,6 +93,7 @@ struct tvec_base {
> struct tvec_base boot_tvec_bases;
> EXPORT_SYMBOL(boot_tvec_bases);
> static DEFINE_PER_CPU(struct tvec_base *, tvec_bases) = &boot_tvec_bases;
> +static DEFINE_PER_CPU(struct tvec_base, __tvec_bases);
>
> /* Functions below help us manage 'deferrable' flag */
> static inline unsigned int tbase_get_deferrable(struct tvec_base *base)
> @@ -1534,46 +1535,25 @@ EXPORT_SYMBOL(schedule_timeout_uninterruptible);
>
> static int init_timers_cpu(int cpu)
> {
> - int j;
> - struct tvec_base *base;
> + struct tvec_base *base = per_cpu(tvec_bases, cpu);
> static char tvec_base_done[NR_CPUS];
> + int j;
>
> if (!tvec_base_done[cpu]) {
> static char boot_done;
>
> + if (!boot_done) {
> + boot_done = 1; /* skip the boot cpu */

So it would be a lot more descriptive to name this flag
'boot_cpu_skipped'?

> } else {
> + base = per_cpu_ptr(&__tvec_bases, cpu);
> + per_cpu(tvec_bases, cpu) = base;
> }
> +
> spin_lock_init(&base->lock);
> tvec_base_done[cpu] = 1;
> base->cpu = cpu;
> }

Also, I'd put a description about the PER_CPU background into comments
as well, because it's not obvious at first sight at all what the whole
(boot_tvec_bases, tvec_bases, __tvec_bases) dance does.

Thanks,

Ingo
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/