[PATCH 05/13] thermal: inline only once used function

From: Sascha Hauer
Date: Thu Mar 26 2015 - 11:54:34 EST


Inline update_temperature into its only caller to make the code
more readable.

Signed-off-by: Sascha Hauer <s.hauer@xxxxxxxxxxxxxx>
---
drivers/thermal/thermal_core.c | 16 +++++-----------
1 file changed, 5 insertions(+), 11 deletions(-)

diff --git a/drivers/thermal/thermal_core.c b/drivers/thermal/thermal_core.c
index ebca854..6d0fdad 100644
--- a/drivers/thermal/thermal_core.c
+++ b/drivers/thermal/thermal_core.c
@@ -431,11 +431,15 @@ exit:
}
EXPORT_SYMBOL_GPL(thermal_zone_get_temp);

-static void update_temperature(struct thermal_zone_device *tz)
+void thermal_zone_device_update(struct thermal_zone_device *tz)
{
+ int count;
unsigned long temp;
int ret;

+ if (!tz->ops->get_temp)
+ return;
+
ret = thermal_zone_get_temp(tz, &temp);
if (ret) {
dev_warn(&tz->device, "failed to read out thermal zone %d\n",
@@ -451,16 +455,6 @@ static void update_temperature(struct thermal_zone_device *tz)
trace_thermal_temperature(tz);
dev_dbg(&tz->device, "last_temperature=%lu, current_temperature=%lu\n",
tz->last_temperature, tz->temperature);
-}
-
-void thermal_zone_device_update(struct thermal_zone_device *tz)
-{
- int count;
-
- if (!tz->ops->get_temp)
- return;
-
- update_temperature(tz);

for (count = 0; count < tz->trips; count++)
handle_thermal_trip(tz, count);
--
2.1.4

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/