Re: [tip:x86/asm] x86/asm/entry/64: Rename 'old_rsp' to 'rsp_scratch'

From: Denys Vlasenko
Date: Tue Mar 17 2015 - 13:58:30 EST


On 03/17/2015 05:43 PM, tip-bot for Ingo Molnar wrote:
> Commit-ID: c38e503804b0402c510f82437069f7769fa0cea9
> Gitweb: http://git.kernel.org/tip/c38e503804b0402c510f82437069f7769fa0cea9
> Author: Ingo Molnar <mingo@xxxxxxxxxx>
> AuthorDate: Tue, 17 Mar 2015 14:42:59 +0100
> Committer: Ingo Molnar <mingo@xxxxxxxxxx>
> CommitDate: Tue, 17 Mar 2015 16:01:42 +0100
>
> x86/asm/entry/64: Rename 'old_rsp' to 'rsp_scratch'
>
> Make clear that the usage of PER_CPU(old_rsp) is purely temporary,
> by renaming it to 'rsp_scratch'.
...
> @@ -657,7 +657,7 @@ common_interrupt:
> ASM_CLAC
> addq $-0x80,(%rsp) /* Adjust vector to [-256,-1] range */
> interrupt do_IRQ
> - /* 0(%rsp): old_rsp */
> + /* 0(%rsp): rsp_scratch */
> ret_from_intr:

Here the "old_rsp" word in comment did not refer to old_rsp variable.

Rather, it literally means "old %rsp register value (before we possibly
switched to per-CPU interrupt stack)".

The stack switch is hidden in "interrupt do_IRQ" macro invocation.

I think here "old_rsp" needs to be replaced by "old rsp" or "old %rsp".

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/