Re: [RFC PATCH] sys_membarrier(): system/process-wide memory barrier (x86) (v12)

From: Mathieu Desnoyers
Date: Mon Mar 16 2015 - 09:00:38 EST


----- Original Message -----
> From: "Josh Triplett" <josh@xxxxxxxxxxxxxxxx>
> To: "Mathieu Desnoyers" <mathieu.desnoyers@xxxxxxxxxxxx>
> Cc: linux-kernel@xxxxxxxxxxxxxxx, "KOSAKI Motohiro" <kosaki.motohiro@xxxxxxxxxxxxxx>, "Steven Rostedt"
> <rostedt@xxxxxxxxxxx>, "Paul E. McKenney" <paulmck@xxxxxxxxxxxxxxxxxx>, "Nicholas Miell" <nmiell@xxxxxxxxxxx>,
> "Linus Torvalds" <torvalds@xxxxxxxxxxxxxxxxxxxx>, "Ingo Molnar" <mingo@xxxxxxxxxx>, "Alan Cox"
> <gnomes@xxxxxxxxxxxxxxxxxxx>, "Lai Jiangshan" <laijs@xxxxxxxxxxxxxx>, "Stephen Hemminger"
> <stephen@xxxxxxxxxxxxxxxxxx>, "Andrew Morton" <akpm@xxxxxxxxxxxxxxxxxxxx>, "Thomas Gleixner" <tglx@xxxxxxxxxxxxx>,
> "Peter Zijlstra" <peterz@xxxxxxxxxxxxx>, "David Howells" <dhowells@xxxxxxxxxx>, "Nick Piggin" <npiggin@xxxxxxxxx>
> Sent: Sunday, March 15, 2015 11:25:50 PM
> Subject: Re: [RFC PATCH] sys_membarrier(): system/process-wide memory barrier (x86) (v12)
>
> On Sun, Mar 15, 2015 at 03:24:19PM -0400, Mathieu Desnoyers wrote:
> > Here is an implementation of a new system call, sys_membarrier(), which
> > executes a memory barrier on either all running threads of the current
> > process (MEMBARRIER_PRIVATE_FLAG) or calls synchronize_sched() to issue
> > a memory barrier on all threads running on the system. It can be used to
> > distribute the cost of user-space memory barriers asymmetrically by
> > transforming pairs of memory barriers into pairs consisting of
> > sys_membarrier() and a compiler barrier. For synchronization primitives
> > that distinguish between read-side and write-side (e.g. userspace RCU,
> > rwlocks), the read-side can be accelerated significantly by moving the
> > bulk of the memory barrier overhead to the write-side.
>
> From a quick review, this seems quite reasonable (as it did 5 years
> ago).
>
> One request: Could you please add a config option (default y) in the
> EXPERT menu to disable this? You actually seem to already have it
> marked as a cond_syscall.

Sure, done.

>
> Also, a very minor nit: flags in kernel APIs aren't typically named with
> a _FLAG suffix.

OK, good point.

>
> With the syscall made optional, and with or without that naming nit
> fixed:
> Reviewed-by: Josh Triplett <josh@xxxxxxxxxxxxxxxx>

Thanks!

Mathieu

>
> - Josh Triplett
>

--
Mathieu Desnoyers
EfficiOS Inc.
http://www.efficios.com
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/