Re: [PATCH v2 1/3] drm: bridge/dw_hdmi: fixed codec style

From: yakir
Date: Mon Mar 09 2015 - 03:25:57 EST



On 2015å03æ09æ 15:05, Daniel Kurtz wrote:
On Mon, Mar 9, 2015 at 12:42 PM, Yakir Yang <ykk@xxxxxxxxxxxxxx> wrote:
- const struct dw_hdmi_mpll_config *mpll_config =
- hdmi->plat_data->mpll_cfg;
- const struct dw_hdmi_curr_ctrl *curr_ctrl = hdmi->plat_data->cur_ctr;
- const struct dw_hdmi_sym_term *sym_term = hdmi->plat_data->sym_term;

+ const struct dw_hdmi_plat_data *plat_data = hdmi->plat_data;
+ const struct dw_hdmi_mpll_config *mpll_config = plat_data->mpll_cfg;
+ const struct dw_hdmi_curr_ctrl *curr_ctrl = plat_data->cur_ctr;
+ const struct dw_hdmi_sym_term *sym_term = plat_data->sym_term;

Signed-off-by: Yakir Yang <ykk@xxxxxxxxxxxxxx>
I agree with Joe Perches that this commit message is not very clear.
It should summarize what the patches is doing and why, not just be a
copy of the change.
e.g., "Using a local struct pointer to reduce one level of indirection
makes the code slightly more readable."

, but otherwise this is:
Reviewed-by: Daniel Kurtz <djkurtz@xxxxxxxxxxxx>

Okay, I will correct it now.

Thanks for your reivew :)

---

Changes in v2: None

drivers/gpu/drm/bridge/dw_hdmi.c | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/drivers/gpu/drm/bridge/dw_hdmi.c b/drivers/gpu/drm/bridge/dw_hdmi.c
index 9ffc257..b9d8d8a 100644
--- a/drivers/gpu/drm/bridge/dw_hdmi.c
+++ b/drivers/gpu/drm/bridge/dw_hdmi.c
@@ -900,10 +900,10 @@ static int hdmi_phy_configure(struct dw_hdmi *hdmi, unsigned char prep,
{
unsigned res_idx, i;
u8 val, msec;
- const struct dw_hdmi_mpll_config *mpll_config =
- hdmi->plat_data->mpll_cfg;
- const struct dw_hdmi_curr_ctrl *curr_ctrl = hdmi->plat_data->cur_ctr;
- const struct dw_hdmi_sym_term *sym_term = hdmi->plat_data->sym_term;
+ const struct dw_hdmi_plat_data *plat_data = hdmi->plat_data;
+ const struct dw_hdmi_mpll_config *mpll_config = plat_data->mpll_cfg;
+ const struct dw_hdmi_curr_ctrl *curr_ctrl = plat_data->cur_ctr;
+ const struct dw_hdmi_sym_term *sym_term = plat_data->sym_term;

if (prep)
return -EINVAL;
--
2.1.2



_______________________________________________
Linux-rockchip mailing list
Linux-rockchip@xxxxxxxxxxxxxxxxxxx
http://lists.infradead.org/mailman/listinfo/linux-rockchip




--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/