Re: [PATCH] i2c: axxia: match return type of wait_for_completion_timeout

From: Nicholas Mc Guire
Date: Sun Feb 08 2015 - 10:44:36 EST


On Sun, 08 Feb 2015, Wolfram Sang wrote:

> On Sun, Feb 08, 2015 at 05:31:25AM -0500, Nicholas Mc Guire wrote:
> > return type of wait_for_completion_timeout is unsigned long not int. as ret
> > is only used for wait_for_completion_timeout here the type is simply changed
> > unsigned long.
> >
> > Signed-off-by: Nicholas Mc Guire <hofrat@xxxxxxxxx>
> > ---
> >
> > Patch was only compile tested with axm55xx_defconfig
> > (implies CONFIG_I2C_AXXIA=y)
> >
> > Patch is against 3.19.0-rc7 (localversion-next is -next-20150204)
> >
> > drivers/i2c/busses/i2c-axxia.c | 2 +-
> > 1 file changed, 1 insertion(+), 1 deletion(-)
> >
> > diff --git a/drivers/i2c/busses/i2c-axxia.c b/drivers/i2c/busses/i2c-axxia.c
> > index 1decc88..9434824 100644
> > --- a/drivers/i2c/busses/i2c-axxia.c
> > +++ b/drivers/i2c/busses/i2c-axxia.c
> > @@ -408,7 +408,7 @@ static int axxia_i2c_xfer_msg(struct axxia_i2c_dev *idev, struct i2c_msg *msg)
> > static int axxia_i2c_stop(struct axxia_i2c_dev *idev)
> > {
> > u32 int_mask = MST_STATUS_ERR | MST_STATUS_SCC;
> > - int ret;
> > + unsigned long ret;
>
> 'ret' being an int is kind of an idiom, so I'd rather see the variable
> renamed, too, like the other patches do.
>
thanks - was not renaming variables - only if a new one was introduced I
gave it a name that was related to the timeout use. Will consider that
for some of the other cleanups then as well.

> Also, please combine the two axxia patches into one.
>
done and resent.

thx!
hofrat
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/