[PATCH v2 0/3] CCF fixes/cleanup for per-user series

From: Stephen Boyd
Date: Fri Feb 06 2015 - 14:42:51 EST


Here are some fixes from yesterdays's dive into the fallout from the
per-user constraints patches. We should do a final sweep later
to rename local variables with type struct clk_core to core.

Changes from v1:
* Picked up tags
* Dropped clk.h include in last patch
* Handled IS_ERR() retrurn from __clk_create_clk() in clkdev in first patch
* Removed dead comment in last patch

Stephen Boyd (3):
clkdev: Always allocate a struct clk and call __clk_get() w/ CCF
clk: Rename child_node to clks_node to avoid confusion
clk: Replace of_clk_get_by_clkspec() with of_clk_get_from_provider()

drivers/clk/clk-conf.c | 7 +++---
drivers/clk/clk.c | 60 +++++++++++++++++++++++++++-----------------------
drivers/clk/clk.h | 22 ++++++++++++++----
drivers/clk/clkdev.c | 57 ++++++++++-------------------------------------
4 files changed, 66 insertions(+), 80 deletions(-)

--
The Qualcomm Innovation Center, Inc. is a member of the Code Aurora Forum,
a Linux Foundation Collaborative Project

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/