Re: [PATCH/RFC v10 06/19] mfd: max77693: modifications around max77693_led_platform_data

From: Pavel Machek
Date: Fri Jan 09 2015 - 12:56:49 EST


On Fri 2015-01-09 16:22:56, Jacek Anaszewski wrote:
> 1. Rename max77693_led_platform_data to max77693_led_config_data to
> avoid making impression that the led driver expects a board file -
> it relies on Device Tree data.
> 2. Remove fleds array, as the DT binding design has changed
> 3. Add "label" array for Device Tree strings with the name of a LED device
> 4. Make flash_timeout a two element array, for caching the sub-led
> related flash timeout.
> 5. Remove trigger array as the related data will not be provided
> in the DT binding
>
> Signed-off-by: Jacek Anaszewski <j.anaszewski@xxxxxxxxxxx>
> Acked-by: Kyungmin Park <kyungmin.park@xxxxxxxxxxx>
> Cc: Chanwoo Choi <cw00.choi@xxxxxxxxxxx>
> Cc: Lee Jones <lee.jones@xxxxxxxxxx>

Seems that max77693_led_platform_data is unused at the moment, so it
should not break bisect.

Acked-by: Pavel Machek <pavel@xxxxxx>

> index f0b6585..c1ccb13 100644
> --- a/include/linux/mfd/max77693.h
> +++ b/include/linux/mfd/max77693.h
> @@ -87,17 +87,16 @@ enum max77693_led_boost_mode {
> MAX77693_LED_BOOST_FIXED,
> };
>
> -struct max77693_led_platform_data {
> - u32 fleds[2];
> +struct max77693_led_config_data {
> + const char *label[2];
> u32 iout_torch[2];
> u32 iout_flash[2];

--
(english) http://www.livejournal.com/~pavelmachek
(cesky, pictures) http://atrey.karlin.mff.cuni.cz/~pavel/picture/horses/blog.html
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/