Re: [PATCH] ioat: fail self-test if wait_for_completion times out

From: Prarit Bhargava
Date: Wed Jan 07 2015 - 07:46:59 EST




On 01/06/2015 10:38 AM, Jiang, Dave wrote:
>>>> - if (dma->device_tx_status(dma_chan, cookie, NULL) != DMA_COMPLETE) {
>>>> + if (tmo == 0 || dma->device_tx_status(dma_chan, cookie, NULL)
>>>> + != DMA_COMPLETE) {
>>>
>>> Can you please do:
>>> + if (tmo == 0 ||
>>> + dma->device_tx_status(dma_chan, cookie, NULL) != DMA_COMPLETE) {
>>
>> Documentation/CodingStyle:Chapter 2
>>
>> "Statements longer than 80 columns will be broken into sensible chunks, unless
>> exceeding 80 columns significantly increases readability and does not hide
>> information. Descendants are always substantially shorter than the parent and
>> are placed substantially to the right. The same applies to function headers..."
>>
>> am I misreading the CodingStyle here ?
>
> I'm not sure what the issue is here.... What I proposed is still the
> same length as the original code. And what I suggested complies with the
> existing coding style that's already there.

Ugh ... I missed this obvious CodingStyle error.

What Dave is trying to say is that he (and I'm pretty sure everyone else
for that matter) disagree with you style change because you have not broken
the columns into "sensible chunks".

IOW ... this,

if (tmo == 0 ||
dma->device_tx_status(dma_chan, cookie, NULL) != DMA_COMPLETE) {

is much easier to comprehend than this,

if (tmo == 0 || dma->device_tx_status(dma_chan, cookie, NULL)
!= DMA_COMPLETE) {

P.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/