Re: Question about my patch

From: NeilBrown
Date: Wed Dec 17 2014 - 00:26:17 EST


On Tue, 16 Dec 2014 23:19:09 -0500 nick <xerofoify@xxxxxxxxx> wrote:

> Greetings Neil,
> As you our the maintainer for this patch I created:
>
> >From ad324f9c2c8117b2f74ad73cb9c6e8185edf5395 Mon Sep 17 00:00:00 2001
> From: Nicholas Krause <xerofoify@xxxxxxxxx>
> Date: Tue, 16 Dec 2014 22:54:10 -0500
> Subject: [PATCH] drivers:md: Remove unneeded argument to the function,
> sync_request in raid5.c
>
> Removes unneeded argument of go_faster for the function sync_request as this parameter is never used in the function. Further more do to this we can remove this parameter for the function sync_request
> in the file, raid5.c safely and not break any callers of this function successfully.
>
> Signed-off-by: Nicholas Krause <xerofoify@xxxxxxxxx>
> ---
> drivers/md/raid5.c | 3 +--
> 1 file changed, 1 insertion(+), 2 deletions(-)
>
> diff --git a/drivers/md/raid5.c b/drivers/md/raid5.c
> index c1b0d52..e7da686 100644
> --- a/drivers/md/raid5.c
> +++ b/drivers/md/raid5.c
> @@ -4986,8 +4986,7 @@ ret:
> return reshape_sectors;
> }
>
> -/* FIXME go_faster isn't used */
> -static inline sector_t sync_request(struct mddev *mddev, sector_t sector_nr, int *skipped, int go_faster)
> +static inline sector_t sync_request(struct mddev *mddev, sector_t sector_nr, int *skipped)
> {
> struct r5conf *conf = mddev->private;
> struct stripe_head *sh;
>
> --
> 2.1.0
>
> I am wondering as I am getting a few build errors if I should sent the patch anyway or create one that has no warnings. Below our the warnings I am getting.
>

Adding new warning is definitely not acceptable.

The only way you could get ride of the warning is to not change the arguments to the function, or
to make the same change to the arguments of every sync_request function.

The former is easier.

i.e. there is no bug here, and nothing to fix.

Thanks,

NeilBrown



> Warnings from Build:
> drivers/md/raid5.c:7047:2: warning: initialization from incompatible pointer type
> .sync_request = sync_request,
> ^
> drivers/md/raid5.c:7047:2: warning: (near initialization for âraid6_personality.sync_requestâ)
> drivers/md/raid5.c:7069:2: warning: initialization from incompatible pointer type
> .sync_request = sync_request,
> ^
> drivers/md/raid5.c:7069:2: warning: (near initialization for âraid5_personality.sync_requestâ)
> drivers/md/raid5.c:7092:2: warning: initialization from incompatible pointer type
> .sync_request = sync_request,
> ^
> Thanks Nick
> P.S. Sorry about the bad layout if it's hard to read tried to do my best to make it readable :).
>

Attachment: pgpKVGLTN1Q8i.pgp
Description: OpenPGP digital signature