RE: [PATCH] phy: phy-samsung-usb2: Don't use same name for driver name and global structure

From: Kamil Debski
Date: Thu Dec 11 2014 - 05:43:45 EST


Hi,

> From: Vivek Gautam [mailto:gautamvivek1987@xxxxxxxxx]
> Sent: Thursday, December 11, 2014 7:30 AM
> To: Kishon Vijay Abraham I; Kamil Debski
> Cc: linux-kernel@xxxxxxxxxxxxxxx; Linux USB Mailing List; Vivek Gautam
> Subject: Re: [PATCH] phy: phy-samsung-usb2: Don't use same name for
> driver name and global structure
>
> On Wed, Nov 12, 2014 at 3:54 PM, Vivek Gautam <gautam.vivek@xxxxxxxxxxx>
> wrote:
> > Using the same driver name for platform driver and a globally defined,
> > structure used throughout the file, looks a bit unpleasing.
> > So changing the driver name from "samsung_usb2_phy_driver" to
> > "samsung_usb2_phy"
> >
> > Signed-off-by: Vivek Gautam <gautam.vivek@xxxxxxxxxxx>
> > Cc: Kamil Debski <k.debski@xxxxxxxxxxx>
> > Cc: Kishon Vijay Abraham I <kishon@xxxxxx>
> > ---
>
> Although just a trivial change, does it look valid ?

I can agree that the naming of this variable is a bit unfortunate.
Changing name of samsung_usb2_phy_driver to samsung_usb2_phy is, as
you said, a minor change and does not change how the driver works.

Acked-by: Kamil Debski <k.debski@xxxxxxxxxxx>

Best wishes,
--
Kamil Debski
Samsung R&D Institute Poland

>
> > drivers/phy/phy-samsung-usb2.c | 4 ++--
> > 1 file changed, 2 insertions(+), 2 deletions(-)
> >
> > diff --git a/drivers/phy/phy-samsung-usb2.c b/drivers/phy/phy-
> samsung-usb2.c
> > index 908949d..2934fb7 100644
> > --- a/drivers/phy/phy-samsung-usb2.c
> > +++ b/drivers/phy/phy-samsung-usb2.c
> > @@ -226,7 +226,7 @@ static int samsung_usb2_phy_probe(struct
> platform_device *pdev)
> > return 0;
> > }
> >
> > -static struct platform_driver samsung_usb2_phy_driver = {
> > +static struct platform_driver samsung_usb2_phy = {
> > .probe = samsung_usb2_phy_probe,
> > .driver = {
> > .of_match_table = samsung_usb2_phy_of_match,
> > @@ -234,7 +234,7 @@ static struct platform_driver
> samsung_usb2_phy_driver = {
> > }
> > };
> >
> > -module_platform_driver(samsung_usb2_phy_driver);
> > +module_platform_driver(samsung_usb2_phy);
> > MODULE_DESCRIPTION("Samsung S5P/EXYNOS SoC USB PHY driver");
> > MODULE_AUTHOR("Kamil Debski <k.debski@xxxxxxxxxxx>");
> > MODULE_LICENSE("GPL v2");
> > --
> > 1.7.10.4
> >
> > --
> > To unsubscribe from this list: send the line "unsubscribe linux-
> kernel" in
> > the body of a message to majordomo@xxxxxxxxxxxxxxx
> > More majordomo info at http://vger.kernel.org/majordomo-info.html
> > Please read the FAQ at http://www.tux.org/lkml/
>
>
>
> --
> Best Regards
> Vivek Gautam
> Samsung R&D Institute, Bangalore
> India

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/