Re: [PATCH v6 01/46] virtio: add low-level APIs for feature bits

From: David Hildenbrand
Date: Fri Nov 28 2014 - 07:11:13 EST


> Add low level APIs to test/set/clear feature bits.
> For use by transports, to make it easier to
> write code independent of feature bit array format.
>
> Signed-off-by: Michael S. Tsirkin <mst@xxxxxxxxxx>
> ---
> include/linux/virtio_config.h | 53 ++++++++++++++++++++++++++++++++++++++++---
> 1 file changed, 50 insertions(+), 3 deletions(-)
>

As these functions really set feature bits, I would rather name them:

virtio_has_feature ...
virtio_set_feature ...
virtio_clear_feature ...

But in general, this looks good to me!

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/