[RFC][PATCH 06/12 v3] tracing: Add a seq_buf_clear() helper and clear len and readpos in init

From: Steven Rostedt
Date: Tue Nov 04 2014 - 11:02:32 EST


From: "Steven Rostedt (Red Hat)" <rostedt@xxxxxxxxxxx>

Add a helper function seq_buf_clear() that resets the len and readpos
fields of a seq_buf. Currently it is only used in the seq_buf_init()
but will be used later when updating the seq_file code.

Signed-off-by: Steven Rostedt <rostedt@xxxxxxxxxxx>
---
include/linux/seq_buf.h | 9 +++++++--
1 file changed, 7 insertions(+), 2 deletions(-)

diff --git a/include/linux/seq_buf.h b/include/linux/seq_buf.h
index a4d114e6f740..064a8604ad33 100644
--- a/include/linux/seq_buf.h
+++ b/include/linux/seq_buf.h
@@ -25,13 +25,18 @@ struct seq_buf {
loff_t readpos;
};

+static inline void seq_buf_clear(struct seq_buf *s)
+{
+ s->len = 0;
+ s->readpos = 0;
+}
+
static inline void
seq_buf_init(struct seq_buf *s, unsigned char *buf, unsigned int size)
{
s->buffer = buf;
s->size = size;
- s->len = 0;
- s->readpos = 0;
+ seq_buf_clear(s);
}

/*
--
2.1.1


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/