Re: [PATCH 7/8] cdrom: cdrom: export sysctl code

From: Joe Perches
Date: Fri Oct 31 2014 - 18:12:42 EST


On Fri, 2014-10-31 at 22:48 +0100, Fabian Frederick wrote:
> -Move all sysctl operations to cdrom_sysctl
> -Remove static/add extern in cdrom.h for some variables
> -Rename debug to cdrom_debug
> -Fix some checkpatch warnings
> -Update cdrom makefile accordingly.
[]
> diff --git a/include/linux/cdrom.h b/include/linux/cdrom.h
[]
> +extern bool cdrom_debug;
> +extern bool autoclose;
> +extern bool autoeject;
> +extern bool lockdoor;
> +extern bool check_media_type;
> +extern bool mrw_format_restart;
> +extern struct list_head cdrom_list;
> +extern struct mutex cdrom_mutex;

I think these should be prefixed with "cdrom_"


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/