Re: [GIT PULL] overlay filesystem v25

From: Paul E. McKenney
Date: Tue Oct 28 2014 - 19:31:33 EST


On Tue, Oct 28, 2014 at 10:55:13PM +0000, Al Viro wrote:
> On Mon, Oct 27, 2014 at 09:11:27PM -0700, Paul E. McKenney wrote:
> > On Tue, Oct 28, 2014 at 01:12:14AM +0000, Al Viro wrote:
> > > On Mon, Oct 27, 2014 at 10:36:21AM -0700, Paul E. McKenney wrote:
> > > > Code making direct use of smp_read_barrier_depends() is harder to read,
> > > > in my experience, but good point on the sparse noise. Maybe a new
> > > > lockless_dereference() primitive? Maybe something like the following?
> > > > (Untested, probably does not even build.)
> > > >
> > > > #define lockless_dereference(p) \
> > > > ({ \
> > > > typeof(*p) *_________p1 = ACCESS_ONCE(p); \
> > > > smp_read_barrier_depends(); /* Dependency order vs. p above. */ \
> > > > _________p1; \
> > > > })
> > >
> > > Hmm... Where would you prefer to put it? rcupdate.h?
> >
> > Good a place as any, I guess. Please see patch below. Left to myself,
> > I would send this along for the next merge window, but please let me
> > know if you would like it sooner.
>
> It's needed sooner, unfortunately. Guys, could you take a look at
> vfs.git#for-linus and comment?

The version in your tree looks good. I will drop my commit in favor
of yours.

The use of lockless_dereference() and smp_mb__before_spinlock() in
d45f00ae43 (overlayfs: barriers for opening upper-layer directory)
looks fine to me. Only nit is lack of space between "=" and
lockless_dereference().

Thanx, Paul

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/