Re: percpu: Define this_cpu_cpumask_var_t_ptr

From: Tejun Heo
Date: Sat Aug 23 2014 - 13:14:24 EST


Hello, Christoph.

On Fri, Aug 22, 2014 at 12:43:25PM -0500, Christoph Lameter wrote:
> It wont accept the wrong type since the this_cpu_* functions will do type
> checking.

It should only accept cpumask_var_t but the macro version accepts
anything that this_cpu_*() can handle.

> > > _t is there because I wanted to include the full "ugly" name of the
> > > variable to make it similarly ugly. It is needed to make the clear
> > > distinction to "struct cpumask *" which does not have these issues.
> >
> > The compiler can enforce that rule easily if the interface functions
> > are properly typed. I think it'd be far better to go with properly
> > typed accessors with less unwieldy names.
>
> What rule are we talking about? Accessors for what?

I meant that if the new accessors you're adding are proper inline
functions, the compiler would be able to verify the specific type they
should take. IOW, let's go for shorter name w/ stricter type
checking.

Thanks.

--
tejun
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/