Re: percpu: Define this_cpu_cpumask_var_t_ptr

From: Tejun Heo
Date: Fri Aug 22 2014 - 12:41:04 EST


Hello, Christoph.

On Thu, Aug 21, 2014 at 08:03:25PM -0500, Christoph Lameter wrote:
> Its a pretty simple function (actually more a name substituion) so I
> did not think it worth creating an inline function.

Unless there are specific reasons like multi-type arg or breaking
hellish definition order dependency, I think we're better off with
inline functions, especially here, as the implementation will happily
accept arguments of the wrong type.

> _t is there because I wanted to include the full "ugly" name of the
> variable to make it similarly ugly. It is needed to make the clear
> distinction to "struct cpumask *" which does not have these issues.

The compiler can enforce that rule easily if the interface functions
are properly typed. I think it'd be far better to go with properly
typed accessors with less unwieldy names.

Thanks.

--
tejun
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/