Re: [PATCH 0/6] trivial cleanup for iommu/vt-d

From: Yijing Wang
Date: Fri Jul 04 2014 - 05:29:29 EST


On 2014/7/4 17:22, Joerg Roedel wrote:
> On Tue, May 20, 2014 at 08:37:46PM +0800, Yijing Wang wrote:
>>
>> Yijing Wang (6):
>> iommu/vt-d: Use list_for_each_safe() to simplify code
>> iommu/vt-d: move up no_iommu and dmar_disabled check
>> iommu/vt-d: clear the redundant assignment in dmar_enable_qi
>> iommu/vt-d: clear the redundant assignment for domain->nid
>> iommu/vt-d: use inline function dma_pte_superpage instead of macros
>> iommu/vt-d: fix reference count in iommu_prepare_isa
>
> Applied patches 1, 3, 4, 5 and 6, thanks. Also added another patch
> on-top, see below.

Thanks a lot!

Yijing.

>
>>From 77c704bebc5d023ece7af32ea18bc3508cdb0007 Mon Sep 17 00:00:00 2001
> From: Joerg Roedel <jroedel@xxxxxxx>
> Date: Fri, 4 Jul 2014 11:19:10 +0200
> Subject: [PATCH] iommu/vt-d: Don't use magic number in dma_pte_superpage
>
> Use the already defined DMA_PTE_LARGE_PAGE for testing
> instead of hardcoding the value again.
>
> Signed-off-by: Joerg Roedel <jroedel@xxxxxxx>
> ---
> drivers/iommu/intel-iommu.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/iommu/intel-iommu.c b/drivers/iommu/intel-iommu.c
> index 9b9f28e..5d86e93 100644
> --- a/drivers/iommu/intel-iommu.c
> +++ b/drivers/iommu/intel-iommu.c
> @@ -304,7 +304,7 @@ static inline bool dma_pte_present(struct dma_pte *pte)
>
> static inline bool dma_pte_superpage(struct dma_pte *pte)
> {
> - return (pte->val & (1 << 7));
> + return (pte->val & DMA_PTE_LARGE_PAGE);
> }
>
> static inline int first_pte_in_page(struct dma_pte *pte)
>


--
Thanks!
Yijing

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/