RE: [PATCH RFC net-next 08/14] bpf: add eBPF verifier

From: David Laight
Date: Thu Jul 03 2014 - 05:14:50 EST


From: Alexei Starovoitov
> >> +#define _(OP) ({ int ret = OP; if (ret < 0) return ret; })
> > +1 to removing the _ macro. If you want to avoid the 3 lines (is there
> > anything in the style guide against "if ((err=OP) < 0) ..." ?), at
>
> assignment and function call inside 'if' ? I don't like such style.
>
> > least use some meaningful macro name (DO_AND_CHECK, or something like
> > that).

It would have to be RETURN_IF_NEGATIVE().
But even then it is skipped by searches for 'return'.

> Try replacing _ with any other name and see how bad it will look.
> I tried with MACRO_NAME and with 'if (err) goto' and with 'if (err) return',
> before I converged on _ macro.
> I think it's a hidden gem of this patch.

No, it is one of those things that 'seems like a good idea at the time',
but causes grief much later on.

Have you considered saving the error code into 'env' and making most of
the functions return if an error is set?
Then the calling code need not check the result of every function call.

David