Re: [PATCH v2] firmware loader: inform direct failure when udev loader is disabled

From: Ming Lei
Date: Wed Jul 02 2014 - 07:21:18 EST


On Wed, Jul 2, 2014 at 7:01 PM, Takashi Iwai <tiwai@xxxxxxx> wrote:
> At Tue, 1 Jul 2014 20:07:53 -0700,
> Luis R. Rodriguez wrote:
>>
>> From: "Luis R. Rodriguez" <mcgrof@xxxxxxxx>
>>
>> Now that the udev firmware loader is optional request_firmware()
>> will not provide any information on the kernel ring buffer if
>> direct firmware loading failed and udev firmware loading is disabled.
>> If no information is needed request_firmware_direct() should be used
>> for optional firmware, at which point drivers can take on the onus
>> over informing of any failures, if udev firmware loading is disabled
>> though we should at the very least provide some sort of information
>> as when the udev loader was enabled by default back in the days.
>>
>> With this change with a simple firmware load test module [0]:
>>
>> Example output without FW_LOADER_USER_HELPER_FALLBACK
>>
>> platform fake-dev.0: Direct firmware load for fake.bin failed
>> with error -2
>>
>> Example with FW_LOADER_USER_HELPER_FALLBACK
>>
>> platform fake-dev.0: Direct firmware load for fake.bin failed with error -2
>> platform fake-dev.0: Falling back to user helper
>>
>> Without this change without FW_LOADER_USER_HELPER_FALLBACK we
>> get no output logged upon failure.
>>
>> Cc: Tom Gundersen <teg@xxxxxxx>
>> Cc: Ming Lei <ming.lei@xxxxxxxxxxxxx>
>> Cc: Greg Kroah-Hartman <gregkh@xxxxxxxxxxxxxxxxxxx>
>> Cc: Abhay Salunke <Abhay_Salunke@xxxxxxxx>
>> Cc: Stefan Roese <sr@xxxxxxx>
>> Cc: Arnd Bergmann <arnd@xxxxxxxx>
>> Cc: Kay Sievers <kay@xxxxxxxx>
>> Cc: Takashi Iwai <tiwai@xxxxxxx>
>> Signed-off-by: Luis R. Rodriguez <mcgrof@xxxxxxxx>
>> ---
>>
>> This v2 modifies the error to always be called and only in the
>> request_firmware_direct case do we not send smoke signals.
>>
>> drivers/base/firmware_class.c | 13 +++++++------
>> include/linux/firmware.h | 15 ++++++++-------
>> 2 files changed, 15 insertions(+), 13 deletions(-)
>>
>> diff --git a/drivers/base/firmware_class.c b/drivers/base/firmware_class.c
>> index 46ea5f4..60d0e53 100644
>> --- a/drivers/base/firmware_class.c
>> +++ b/drivers/base/firmware_class.c
>> @@ -109,6 +109,7 @@ static inline long firmware_loading_timeout(void)
>> #else
>> #define FW_OPT_FALLBACK 0
>> #endif
>> +#define FW_OPT_DIRECT_ONLY (1U << 3)
>
> I'd name it like FW_OPT_NO_WARN or such.
> Other than that, looks good to me.

IMO, DIRECT_ONLY is better because it can be
extend to other usages in future.

Thanks,
--
Ming Lei
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/