[PATCH] perf/x86/uncore: Remove unnecessary assignment to "box" in uncore_pci_remove(...)

From: Giedrius Rekasius
Date: Thu May 29 2014 - 16:51:15 EST


Local variable "box" gets assigned correct value when it is initialized.
There is no need to assign the same value again. Variable declarations
were reshuffled for better readability.

Signed-off-by: Giedrius Rekasius <giedrius.rekasius@xxxxxxxxx>
---
Original patch was amended for better readability based on feedback from Walter
Harms and Thomas Gleixner.

arch/x86/kernel/cpu/perf_event_intel_uncore.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)

diff --git a/arch/x86/kernel/cpu/perf_event_intel_uncore.c b/arch/x86/kernel/cpu/perf_event_intel_uncore.c
index 65bbbea..6fe20db 100644
--- a/arch/x86/kernel/cpu/perf_event_intel_uncore.c
+++ b/arch/x86/kernel/cpu/perf_event_intel_uncore.c
@@ -3813,11 +3813,10 @@ static int uncore_pci_probe(struct pci_dev *pdev, const struct pci_device_id *id

static void uncore_pci_remove(struct pci_dev *pdev)
{
+ int i, cpu, phys_id = pcibus_to_physid[pdev->bus->number];
struct intel_uncore_box *box = pci_get_drvdata(pdev);
struct intel_uncore_pmu *pmu;
- int i, cpu, phys_id = pcibus_to_physid[pdev->bus->number];

- box = pci_get_drvdata(pdev);
if (!box) {
for (i = 0; i < UNCORE_EXTRA_PCI_DEV_MAX; i++) {
if (extra_pci_dev[phys_id][i] == pdev) {
--
1.9.3

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/