Re: [Patch Part3 V1 17/22] pci, ACPI, iommu: enhance pci_root to support DMAR device hotplug

From: Jiang Liu
Date: Mon May 05 2014 - 04:23:06 EST




On 2014/4/25 1:33, Bjorn Helgaas wrote:
> On Tue, Apr 22, 2014 at 03:07:28PM +0800, Jiang Liu wrote:
>> Finally enhance pci_root driver to support DMAR device hotplug when
>> hot-plugging PCI host bridges.
>>
>> Signed-off-by: Jiang Liu <jiang.liu@xxxxxxxxxxxxxxx>
>> ---
>> drivers/acpi/pci_root.c | 16 ++++++++++++++--
>> 1 file changed, 14 insertions(+), 2 deletions(-)
>>
>> diff --git a/drivers/acpi/pci_root.c b/drivers/acpi/pci_root.c
>> index d388f13d48b4..aa8f549869f3 100644
>> --- a/drivers/acpi/pci_root.c
>> +++ b/drivers/acpi/pci_root.c
>> @@ -33,6 +33,7 @@
>> #include <linux/pci.h>
>> #include <linux/pci-acpi.h>
>> #include <linux/pci-aspm.h>
>> +#include <linux/dmar.h>
>> #include <linux/acpi.h>
>> #include <linux/slab.h>
>> #include <acpi/apei.h> /* for acpi_hest_init() */
>> @@ -511,6 +512,7 @@ static int acpi_pci_root_add(struct acpi_device *device,
>> struct acpi_pci_root *root;
>> acpi_handle handle = device->handle;
>> int no_aspm = 0, clear_aspm = 0;
>> + bool hotadd = (system_state != SYSTEM_BOOTING);
>>
>> root = kzalloc(sizeof(struct acpi_pci_root), GFP_KERNEL);
>> if (!root)
>> @@ -557,6 +559,11 @@ static int acpi_pci_root_add(struct acpi_device *device,
>> strcpy(acpi_device_class(device), ACPI_PCI_ROOT_CLASS);
>> device->driver_data = root;
>>
>> + if (hotadd && dmar_device_hotplug(handle, true)) {
>
> Apparently "dmar_device_hotplug(handle, true)" means "add a DMAR device,"
> and "dmar_device_hotplug(device->handle, false)" means "remove a DMAR
> device." I'm not really a fan of interfaces where one of the arguments
> selects between two completely different actions, because it's harder for a
> casual reader to see what's going on.
>
> I see how it simplifies your implementation a little bit, but I think it's
> more important to simplify for the reader.
Thanks Bjorn, I will rename it to dmar_device_add/remove() instead.

>
> Bjorn
>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/