Re: [PATCH tip/core/rcu 0/3] Miscellaneous fixes for 3.16

From: Paul E. McKenney
Date: Tue Apr 29 2014 - 11:46:26 EST


On Mon, Apr 28, 2014 at 08:23:45PM -0700, Josh Triplett wrote:
> On Mon, Apr 28, 2014 at 04:56:00PM -0700, Paul E. McKenney wrote:
> > Hello!
> >
> > This series provides miscellaneous fixes:
> >
> > 1. Apply ACCESS_ONCE() to unprotected ->gp_flags accesses.
> >
> > 2. Fix typo in comment, courtesy of Liu Ping Fan.
> >
> > 3. Make RCU CPU stall warnings print grace-period numbers in
> > signed format to improve readability of stall-warning output.
> >
> > 4. Make cpu_needs_another_gp() take future grace-period needs
> > into account.
> >
> > 5. Remove unused ->preemptible field from the rcu_data structure,
> > courtesty of Iulia Manda.
> >
> > 6. Apply ACCESS_ONCE() to unprotected ->jiffies_stall accesses,
> > courtesty of Iulia Manda.
> >
> > 7. Make callers responsible for grace-period kthread wakeup in
> > order to avoid potential silent grace-period stalls.
> >
> > 8. Remove "extern" from RCU function declarations, courtesy of
> > Iulia Manda.
> >
> > 9. Apply ACCESS_ONCE() to additional ->jiffies_stall accesses,
> > courtesy of Himangi Saraogi.
> >
> > 10. Add event tracing to dyntick_save_progress_counter(), courtesy
> > of Andreea-Cristina Bernat.
> >
> > 11. Make rcu_init_one() use nr_cpu_ids instead of NR_CPUS for
> > data-structure setup limit check, courtesy of Himangi Saraogi.
> >
> > 12. Remove redundant kfree_call_rcu() definition by using the
> > rcu_state pointer, courtesy of Andreea-Cristina Bernat.
> >
> > 13. Merge rcu_sched_force_quiescent_state() definition with
> > rcu_force_quiescent_state() by using the rcu_state pointer,
> > courtesy of Andreea-Cristina Bernat.
> >
> > 14. Document RCU_INIT_POINTER()'s lack of ordering guarantees.
> >
> > 15. Automatically bind RCU's grace-period kthreads to timekeeping
> > CPU for NO_HZ_FULL builds.
> >
> > 16. Make large and small sysidle systems use equivalent state machine.
> >
> > 17. Remove duplicate resched_cpu() declaration, courtesy of
> > Pranith Kumar.
> >
> > 18. Replace deprecated __this_cpu_ptr() uses with raw_cpu_ptr(),
> > courtesy of Christoph Lameter.
> >
> > 19. Make softirq processing provide a quiescent state only once
> > per full pass over all softirqs rather than once per action,
> > courtesy of Eric Dumazet.
>
> For all 19:
> Reviewed-by: Josh Triplett <josh@xxxxxxxxxxxxxxxx>

And thank you for these reviews as well, applied!

Thanx, Paul

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/