[PATCH v2 0/2] ahci: Tweaks to the driver's PCI function

From: Alexander Gordeev
Date: Thu Apr 17 2014 - 09:12:33 EST


Changes since v1:
- ahci_is_mrsm() open-coded inside ahci_init_interrupt()
- changelog elaborated

Cc: linux-ide@xxxxxxxxxxxxxxx

Alexander Gordeev (2):
ahci: Ensure "MSI Revert to Single Message" mode is not enforced
ahci: Use pci_enable_msi_exact() instead of pci_enable_msi_range()

drivers/ata/ahci.c | 19 ++++++++++++++-----
drivers/ata/ahci.h | 1 +
2 files changed, 15 insertions(+), 5 deletions(-)

--
1.7.7.6

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/