Re: [PATCH 1/6] usb: gadget: gr_udc: Make struct platform_device variable name clearer

From: Felipe Balbi
Date: Tue Feb 25 2014 - 13:10:24 EST


On Mon, Feb 24, 2014 at 08:40:17AM +0100, Andreas Larsson wrote:
> On 2014-02-18 16:52, Felipe Balbi wrote:
> >On Thu, Jan 09, 2014 at 11:54:13AM +0100, Andreas Larsson wrote:
> >>Rename struct platform_device pointers from ofdev to pdev for clarity.
> >>Suggested by Mark Rutland.
> >>
> >>Signed-off-by: Andreas Larsson <andreas@xxxxxxxxxxx>
> >>---
> >> drivers/usb/gadget/gr_udc.c | 18 +++++++++---------
> >> 1 file changed, 9 insertions(+), 9 deletions(-)
> >>
> >>diff --git a/drivers/usb/gadget/gr_udc.c b/drivers/usb/gadget/gr_udc.c
> >>index 914cbd8..e66dcf0 100644
> >>--- a/drivers/usb/gadget/gr_udc.c
> >>+++ b/drivers/usb/gadget/gr_udc.c
> >>@@ -2071,9 +2071,9 @@ static int gr_udc_init(struct gr_udc *dev)
> >> return 0;
> >> }
> >>
> >>-static int gr_remove(struct platform_device *ofdev)
> >>+static int gr_remove(struct platform_device *pdev)
> >> {
> >>- struct gr_udc *dev = dev_get_drvdata(&ofdev->dev);
> >>+ struct gr_udc *dev = dev_get_drvdata(&pdev->dev);
> >
> >you can use platform_get_drvdata()
> >
> >>@@ -2083,7 +2083,7 @@ static int gr_remove(struct platform_device *ofdev)
> >> gr_dfs_delete(dev);
> >> if (dev->desc_pool)
> >> dma_pool_destroy(dev->desc_pool);
> >>- dev_set_drvdata(&ofdev->dev, NULL);
> >>+ dev_set_drvdata(&pdev->dev, NULL);
> >
> >and platform_set_drvdata()
> >
>
> Yes, but wouldn't that be better handled in a separate patch?

not necessary, you're adding the platform_device argument to this patch
anyway.

--
balbi

Attachment: signature.asc
Description: Digital signature