Re: [PATCH] hwmon: (max6650) Rename the device ids to contain thehwmon suffix

From: Lee Jones
Date: Mon Feb 10 2014 - 11:09:29 EST


> In the preparation of creating an mfd driver and then refactor this one into a
> platform driver in order to add some pinctrl functionality to the chip, it is
> necessary to start the series with this change so that the mfd driver can refer
> to the proper name in the subsequent change without making changes in more than
> one driver later.
>
> This was a request from Lee Jones, the MFD subsystem maintainer.
>
> Signed-off-by: Laszlo Papp <lpapp@xxxxxxx>
> ---
> drivers/hwmon/max6650.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/hwmon/max6650.c b/drivers/hwmon/max6650.c
> index 0cafc39..3c36edc 100644
> --- a/drivers/hwmon/max6650.c
> +++ b/drivers/hwmon/max6650.c
> @@ -116,8 +116,8 @@ static struct max6650_data *max6650_update_device(struct device *dev);
> */
>
> static const struct i2c_device_id max6650_id[] = {
> - { "max6650", 1 },
> - { "max6651", 4 },
> + { "max6650-hwmon", 1 },
> + { "max6651-hwmon", 4 },

Might be worth taking the opportunity to swap out these magic numbers
now.

> { }
> };
> MODULE_DEVICE_TABLE(i2c, max6650_id);

--
Lee Jones
Linaro STMicroelectronics Landing Team Lead
Linaro.org â Open source software for ARM SoCs
Follow Linaro: Facebook | Twitter | Blog
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/