Re: [PATCH v11] gpio: add a driver for the Synopsys DesignWare APBGPIO block

From: Linus Walleij
Date: Mon Feb 10 2014 - 06:06:54 EST


Hi Alan, this is starting to look good. I's like an ACK from a DT
maintainer on the bindings but can't see anything really controversial
about them.

On Thu, Feb 6, 2014 at 11:06 PM, Alan Tull <delicious.quinoa@xxxxxxxxx> wrote:

> +static int dwapb_gpio_to_irq(struct gpio_chip *gc, unsigned offset)
> +{
> + struct bgpio_chip *bgc = to_bgpio_chip(gc);
> + struct dwapb_gpio_port *port = container_of(bgc, struct
> + dwapb_gpio_port, bgc);
> + struct dwapb_gpio *gpio = port->gpio;
> +
> + return irq_create_mapping(gpio->domain, offset);
> +}

I think you want to call irq_find_mapping() here. irq_create_mapping()
should be called for all valid IRQs on probe() instead.

> + ct = irq_gc->chip_types;
> + ct->chip.irq_ack = irq_gc_ack_set_bit;
> + ct->chip.irq_mask = irq_gc_mask_set_bit;
> + ct->chip.irq_unmask = irq_gc_mask_clr_bit;
> + ct->chip.irq_set_type = dwapb_irq_set_type;
> + ct->chip.irq_enable = dwapb_irq_enable;
> + ct->chip.irq_disable = dwapb_irq_disable;
> + ct->regs.ack = GPIO_PORTA_EOI;
> + ct->regs.mask = GPIO_INTMASK;

Please add .startup() and .shutdown() callbacks marking the
respective lines as IRQs, compare to recent patches in the
GPIO subsystem such as this:
http://marc.info/?l=linux-gpio&m=138546100215235&w=2

You probably want to call irq_create_mapping() for each
valid IRQ after registering the chip in this function.

Yours,
Linus Walleij
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/