Re: [PATCH 1/3] mm: vmscan: shrink_slab: rename max_pass ->freeable

From: David Rientjes
Date: Tue Jan 21 2014 - 17:22:34 EST

On Fri, 17 Jan 2014, Vladimir Davydov wrote:

> The name `max_pass' is misleading, because this variable actually keeps
> the estimate number of freeable objects, not the maximal number of
> objects we can scan in this pass, which can be twice that. Rename it to
> reflect its actual meaning.
> Signed-off-by: Vladimir Davydov <vdavydov@xxxxxxxxxxxxx>
> Cc: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx>
> Cc: Mel Gorman <mgorman@xxxxxxx>
> Cc: Michal Hocko <mhocko@xxxxxxx>
> Cc: Johannes Weiner <hannes@xxxxxxxxxxx>
> Cc: Rik van Riel <riel@xxxxxxxxxx>
> Cc: Dave Chinner <dchinner@xxxxxxxxxx>
> Cc: Glauber Costa <glommer@xxxxxxxxx>

This doesn't compile on linux-next:

mm/vmscan.c: In function âshrink_slab_nodeâ:
mm/vmscan.c:300:23: error: âmax_passâ undeclared (first use in this function)
mm/vmscan.c:300:23: note: each undeclared identifier is reported only once for each function it appears in

because of b01fa2357bca ("mm: vmscan: shrink all slab objects if tight on
memory") from an author with a name remarkably similar to yours. Could
you rebase this series on top of your previous work that is already in