Re: [PATCH net-next 1/2] random32: add prandom_u32_lt_N and convert"misuses" of reciprocal_divide

From: Daniel Borkmann
Date: Thu Jan 16 2014 - 04:31:13 EST


On 01/16/2014 04:14 AM, Eric Dumazet wrote:
On Thu, 2014-01-16 at 00:23 +0100, Daniel Borkmann wrote:

@@ -1220,7 +1219,7 @@ static unsigned int fanout_demux_hash(struct packet_fanout *f,
struct sk_buff *skb,
unsigned int num)
{
- return reciprocal_divide(skb->rxhash, num);
+ return (u32)(((u64) skb->rxhash * num) >> 32);
}


This is unfortunate.

Hm, I agree, it would be better to have a function here. It was mostly
for the purpose of the 2nd patch to migrate users since the structure
was introduced, and thus they become incompatible.

(This reverts one of your patch : f55d112e529386 )

Please add a helper to explain what's going on here, and on many other
spots we do this computation (as in get_rps_cpu()).
Few people really understand this.

Indeed, that's why we also thought that we should fix some spots in
the second patch, also with the thought in mind, when upcoming users
have to use a structure to enforce this call combination.

Anyway, we'll wait for some more feedback anyway regarding the 2nd patch
and then respin.

Or keep reciprocal_divide() as is, and introduce a new set of functions
for people really wanting the precise divides.

That might also be a possible option, we could consider. Thanks!




--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/