Re: [PATCH v2 3/5] fat: zero out seek range on _fat_get_block

From: OGAWA Hirofumi
Date: Sun Dec 01 2013 - 07:49:42 EST


Namjae Jeon <linkinjeon@xxxxxxxxx> writes:

> --- a/fs/fat/cache.c
> +++ b/fs/fat/cache.c
> @@ -334,7 +334,8 @@ int fat_bmap(struct inode *inode, sector_t sector, sector_t *phys,
> */
> last_block = (MSDOS_I(inode)->i_disksize + (blocksize - 1))
> >> blocksize_bits;
> - if (sector >= last_block)
> + if (sector >= last_block &&
> + MSDOS_I(inode)->mmu_private == MSDOS_I(inode)->i_disksize)
> return 0;

This is strange check. Why do we want to map even if "sector > ->i_disksize"
(when ->mmu_private != ->i_disksize)?


Another point, for ->bmap(), maybe we will need new flag to read beyond
->i_size? Because ->bmap() returns physical address even if > ->i_size.

> diff --git a/fs/fat/inode.c b/fs/fat/inode.c
> index 655dcc7..12a37a9 100644
> --- a/fs/fat/inode.c
> +++ b/fs/fat/inode.c
> @@ -61,15 +61,26 @@ static inline int __fat_get_block(struct inode *inode, sector_t iblock,
> struct super_block *sb = inode->i_sb;
> struct msdos_sb_info *sbi = MSDOS_SB(sb);
> unsigned long mapped_blocks;
> - sector_t phys;
> + sector_t phys, last_block, disk_block;
> int err, offset;
> + const unsigned long blocksize = sb->s_blocksize;
> + const unsigned char blocksize_bits = sb->s_blocksize_bits;
>
> err = fat_bmap(inode, iblock, &phys, &mapped_blocks, create);
> if (err)
> return err;
> if (phys) {
> - map_bh(bh_result, sb, phys);
> *max_blocks = min(mapped_blocks, *max_blocks);
> + last_block = (MSDOS_I(inode)->mmu_private + (blocksize - 1))
> + >> blocksize_bits;
> + disk_block = (MSDOS_I(inode)->i_disksize + (blocksize - 1))
> + >> blocksize_bits;
> + if (iblock >= last_block && iblock <= disk_block) {
> + MSDOS_I(inode)->mmu_private +=
> + *max_blocks << blocksize_bits;
> + set_buffer_new(bh_result);
> + }
> + map_bh(bh_result, sb, phys);
> return 0;
> }
> if (!create)

Let's give the name for this operation for readability, and make it
static function. With this, I think this one much readable.

static void check_fallocate_region()
{
/* code here */
}
--
OGAWA Hirofumi <hirofumi@xxxxxxxxxxxxxxxxxx>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/