Re: [PATCH 4/4] net, virtio_net: replace the magic value

From: Zhi Yong Wu
Date: Mon Nov 18 2013 - 05:08:05 EST


On Mon, Nov 18, 2013 at 5:50 PM, Michael S. Tsirkin <mst@xxxxxxxxxx> wrote:
> On Mon, Nov 18, 2013 at 04:46:20PM +0800, Zhi Yong Wu wrote:
>> From: Zhi Yong Wu <wuzhy@xxxxxxxxxxxxxxxxxx>
>>
>> It is more appropriate to use # of queue pairs currently used by
>> the driver instead of a magic value.
>>
>> Signed-off-by: Zhi Yong Wu <wuzhy@xxxxxxxxxxxxxxxxxx>
>
> I don't mind, but driver should be submitted separately
> from qemu patches. As it is only patch 4/4 made it to netdev.
ok, i will sent v2. By the way, can you help take a look at the
following patches? Maybe i can send their v2 together.
[PATCH 1/3] vhost: remove the dead branch
[PATCH 2/3] vhost: adjust vhost_dev_init() to be void
[PATCH 3/3] vhost: fix the wrong log descriptions


>
>> ---
>> drivers/net/virtio_net.c | 4 ++--
>> 1 files changed, 2 insertions(+), 2 deletions(-)
>>
>> diff --git a/drivers/net/virtio_net.c b/drivers/net/virtio_net.c
>> index cdc7c90..e0cb2d1 100644
>> --- a/drivers/net/virtio_net.c
>> +++ b/drivers/net/virtio_net.c
>> @@ -1619,8 +1619,8 @@ static int virtnet_probe(struct virtio_device *vdev)
>> if (err)
>> goto free_stats;
>>
>> - netif_set_real_num_tx_queues(dev, 1);
>> - netif_set_real_num_rx_queues(dev, 1);
>> + netif_set_real_num_tx_queues(dev, vi->curr_queue_pairs);
>> + netif_set_real_num_rx_queues(dev, vi->curr_queue_pairs);
>>
>> err = register_netdev(dev);
>> if (err) {
>> --
>> 1.7.6.5
>>



--
Regards,

Zhi Yong Wu
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/