Re: [PATCH 2/3] rcu: Create rcu_sync infrastructure

From: Paul E. McKenney
Date: Thu Oct 03 2013 - 13:15:44 EST


On Thu, Oct 03, 2013 at 07:00:52PM +0200, Oleg Nesterov wrote:
> On 10/03, Paul E. McKenney wrote:
> >
> > How about the something like the following, where ->read_side_check()
> > gets rcu_read_lock_held(), rcu_read_lock_bh_held(), or
> > rcu_read_lock_sched_held(), as appropriate?
> >
> > #ifdef CONFIG_PROVE_RCU
> > #define rcu_sync_is_idle_check(rss) BUG_ON(!rss->read_side_check())
> > #else
> > #define rcu_sync_is_idle_check(rss) do { } while (0)
> > #endif
> >
> > rcu_sync_is_idle_check(rss);
>
> Agreed!
>
> but can't we do this in a separate patch? (I will be happy to do
> this trivial exercise ;)

I am good with that.

> This change is trivial, but perhaps it would be better to keep the
> initial patch as simple as possible. And discuss the potential
> "cosmetic" issues (like naming) separately. Say, rcu_lockdep_assert.
> We can't use it directly, we need the new helper.

OK, with s/xxx_/rcu_sync_/ in the comit log:

Reviewed-by: Paul E. McKenney <paulmck@xxxxxxxxxxxxxxxxxx>

But someone else needs to lock all the candidate names in a room
overnight and tend to the resulting wounds. ;-)

Thanx, Paul

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/